Lots of smoke when stopped at lights - KTM Forums: KTM Motorcycle Forum
 1Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 23 (permalink) Old 01-11-2017, 01:01 AM Thread Starter
Silver Member
 
Join Date: Jan 2015
Location: Sydney
Posts: 252
Lots of smoke when stopped at lights

I was on my commute home earlier, and when I was at a set of lights I noticed a bad smell and lots of smoke coming out of my exhaust.

When I got home there wasn't really any coming out but the bike felt really ****ing hot.
Now it is 32 outside atm (90F) so its kind of hot but my temp gauge was only around 80-90% of max so Im not sure if I should go of feel and assume the temp sensor could be off

Oil level seems normal but I may have over filled it a few weeks ago as I wasn't being precise, I might have a coolant leak somewhere as I had to top up a few weeks ago :/

I'll probably drop the bike in for a service when I get the chance this week as I'm due for one but any ideas on what it could be.
weet is online now  
Sponsored Links
Advertisement
 
post #2 of 23 (permalink) Old 01-11-2017, 05:20 AM
Mega Poster
 
hyperpete's Avatar
 
Join Date: Jun 2012
Location: Surfers Paradise, QLD.
Posts: 804
Smoke isn't a good sign! I thought over filling would result in more oil being spat out into the airbox?
Mine often smells like an oily rag after a good day out when I'm parked but the smell doesn't linger when it cools off.
I'd get it looked at
We've got 32c daily here now and mine feels real hot and runs just under the top bar in traffic but lowers a few bars after a kilometer of free ride...
Good luck,be interesting to see what you find.
hyperpete is online now  
post #3 of 23 (permalink) Old 01-11-2017, 07:49 AM
Silver Member
 
Join Date: May 2014
Location: Pennsylvania
Posts: 275
Depends on the color and smell if the smoke. White is usually unburnt fuel (and smells like it). Blue is oil. Overfilling it is unlikely to produce smoke.

'61 BSA Clubman's Gold Star, '13 Daytona 675R (track bike), '13 Duke 690, '14 Street Triple R
Chip is offline  
 
post #4 of 23 (permalink) Old 01-11-2017, 08:55 AM
Junior Member
 
Join Date: Oct 2016
Location: Sunshine Coast Qld.
Posts: 24
You reckon it was smoke not steam?
Sideshow is online now  
post #5 of 23 (permalink) Old 01-11-2017, 04:37 PM
Platinum Member
KTM Forums Team Racer
 
Boldor's Avatar
 
Join Date: Jun 2012
Location: Newcastle, Australia
Posts: 4,892
Any chance you just cleaned it? I hear Sideshow's suggestion, but I am in the habit of wiping stuff down with WD40 too.
Boldor is offline  
post #6 of 23 (permalink) Old 01-11-2017, 05:12 PM Thread Starter
Silver Member
 
Join Date: Jan 2015
Location: Sydney
Posts: 252
I wasn't able to replicate the smoke,

So I'm not sure what it was.

my bikes booked in for a minor service and the ABS recall thing next week anyway
weet is online now  
post #7 of 23 (permalink) Old 01-11-2017, 07:23 PM
Platinum Member
KTM Forums Team Racer
 
Boldor's Avatar
 
Join Date: Jun 2012
Location: Newcastle, Australia
Posts: 4,892
Well get it sorted, Mate. Have a look at what you're doing.

http://www.smh.com.au/national/healt...10-gtor4m.html
Boldor is offline  
post #8 of 23 (permalink) Old 01-12-2017, 01:02 AM Thread Starter
Silver Member
 
Join Date: Jan 2015
Location: Sydney
Posts: 252
I just double checked and my oil was kind of low :/

Topped it up with around 100ml
weet is online now  
post #9 of 23 (permalink) Old 01-19-2017, 04:24 AM Thread Starter
Silver Member
 
Join Date: Jan 2015
Location: Sydney
Posts: 252
Got my bike back with the ABS fix and ****.

They basically said they couldn't find anything wrong

Any ideas what it could be?
weet is online now  
post #10 of 23 (permalink) Old 01-19-2017, 04:33 AM
Full Throttle
 
cors187's Avatar
 
Join Date: May 2016
Location: Helsinki
Posts: 1,101
Quote:
Originally Posted by weet View Post
Got my bike back with the ABS fix and ****.

They basically said they couldn't find anything wrong

Any ideas what it could be?
Please reply with exactly what you are seeing now from your bike.?

I read above but i got confused, i must be to old.

current -2007690SM
cors187 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the KTM Forums: KTM Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome