KTM Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi all - I'm new to the forum so sorry if I have posted this in the wrong section.

I have a 2015 KTM 450EXC (fuel injected), has been a great bike but the last time I rode it I had trouble with it losing power suddenly and then it would die all together. Fortunately I was close to home and after it would die I would try and restart the bike and it would run for maybe another minute or two and then die again. It did this maybe a dozen times before I was able to get home.

I suspect a fuel pump or fuel filter issue. The fuel in the bike was not an issue, clean fuel and 98 octane rating. The engine was not making any abnormal sounds and I don't believe it to be a mechanical issue.

I was hoping someone on the forum has had a similar issue with the same model bike and could tell me what they experienced and how they fixed the issue.

Cheers,
Eric
 

·
Registered
Joined
·
3 Posts
Discussion Starter #2
2015 450EXC won't run??

Hi all - I'm new to the forum so sorry if I have posted this in the wrong section.

I have a 2015 KTM 450EXC (fuel injected), has been a great bike but the last time I rode it I had trouble with it losing power suddenly and then it would die all together. Fortunately I was close to home and after it would die I would try and restart the bike and it would run for maybe another minute or two and then die again. It did this maybe a dozen times before I was able to get home.

I suspect a fuel pump or fuel filter issue. The fuel in the bike was not an issue, clean fuel and 98 octane rating. The engine was not making any abnormal sounds and I don't believe it to be a mechanical issue.

I was hoping someone on the forum has had a similar issue with the same model bike and could tell me what they experienced and how they fixed the issue.

Cheers,
Eric
 

·
Registered
Joined
·
4 Posts
Sounds similar to my issue. I was riding at high speed then the motor started cutting out, then eventually died altogether. I was initially getting a code of R04 on the display, along with the fuel and engine warning lights. I let the bike sit about 10 mins and eventually codes cleared and it started up. Rode it a few miles then it happened again. I did that 3 times trying to get closer to home. The last time the codes went away and I'm left with the fuel light on. And yes, theres plenty of fuel in the tank.

I also believe it's electrical. Any Ideas?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Hey cyarbrough, I talked to the guys at my local KTM shop and told them what was going on. They thought that as my bike only had 70 hrs on it that it was unlikely to be a fuel pump issue, the mechanic recommended that I change my inline fuel filter (on the fuel line coming off the bottom of the tank) and also said I should change the spark plug. I replaced both the plug and filter and it has not given me any trouble since. The other thing I should mention is that there may have been water in the electrical system somewhere when the bike was giving me trouble last time as the tracks I was riding were pretty wet. Good luck with your issue mate!
 

·
Registered
Joined
·
4 Posts
Glad to hear it's no longer a problem. I read somewhere about someone changing the battery in the speedo and so I tried it. Seems to work now. Seems crazy that would be the issue. Guess I'll have to keep a spare watch battery in my gear in case it happens again somewhere less friendly like the middle of Baja.
 

·
Registered
Joined
·
2 Posts
Hi all - I'm new to the forum so sorry if I have posted this in the wrong section.

I have a 2015 KTM 450EXC (fuel injected), has been a great bike but the last time I rode it I had trouble with it losing power suddenly and then it would die all together. Fortunately I was close to home and after it would die I would try and restart the bike and it would run for maybe another minute or two and then die again. It did this maybe a dozen times before I was able to get home.

I suspect a fuel pump or fuel filter issue. The fuel in the bike was not an issue, clean fuel and 98 octane rating. The engine was not making any abnormal sounds and I don't believe it to be a mechanical issue.

I was hoping someone on the forum has had a similar issue with the same model bike and could tell me what they experienced and how they fixed the issue.

Cheers,
Eric
HAD 2018 KTM 450 THAT THE ROCKER STUCK TO ROCKER SHAFT DO NOT KNOW WHY BUT MADE A YOUTUBE VIDEO REPAIR, SEARCH DEWAYNE PEARSON.
 

·
Registered
Joined
·
2 Posts
HAD 2018 KTM 450 THAT THE ROCKER STUCK TO ROCKER SHAFT DO NOT KNOW WHY BUT MADE A YOUTUBE VIDEO REPAIR, SEARCH DEWAYNE PEARSON
 
1 - 7 of 7 Posts
Top