KTM Forums banner
21 - 40 of 44 Posts

·
Registered
2022 SDR Evo
Joined
·
66 Posts
Discussion Starter · #21 ·
Well...it has been starting on the first try since the last incident where it took three tries. I am wondering if it somehow lost the short term fuel learning since my fuel range changed from 150 to 130 also. It went back up to 150 like it was before and has been starting normally.
 

·
Registered
2022 SDR Evo
Joined
·
66 Posts
Discussion Starter · #23 ·
Just another update. Bike started right up this morning after sitting for a day.

BUT...I decided to just give it a little bit of throttle while it was sitting there after like 5 seconds...it didn't like that at all...it immediately kinda choked and shut off. It started right back up and was fine after that though. Wonder if it is still learning...?
 

·
Registered
Joined
·
2 Posts
I've got a EVO that did it when the dealer tried starting it when I picked it up new. I experience the same thing as you. Some time it starts fine cold, sometimes it takes multiple attempts (usually 3 attempts). when warm (engine) it starts every single time. When engine is ambient temp is when the problem sometimes happens. It's been at my dealer for a week now. Last I heard they were going to do a remote link to KTM to see what they think. I will let you know what I learn...
 

·
Registered
2022 SDR Evo
Joined
·
66 Posts
Discussion Starter · #26 ·
I've got a EVO that did it when the dealer tried starting it when I picked it up new. I experience the same thing as you. Some time it starts fine cold, sometimes it takes multiple attempts (usually 3 attempts). when warm (engine) it starts every single time. When engine is ambient temp is when the problem sometimes happens. It's been at my dealer for a week now. Last I heard they were going to do a remote link to KTM to see what they think. I will let you know what I learn...
When I got my Tech Pack installed at a different shop I was talking to the owner and he said that the bike was probably not initialized correctly from the start (I've heard nothing good about the service department where I purchased the bike. That's why I went somewhere else.) He said that all the adaptive values need to be reset and it is supposed to just idle without touching anything for 5min afterwards. He did not have time to do it that day, but said it "should" clear up on its own. It will just take more time without resetting everything. Well...I think he was correct because it did eventually quit taking multiple attempts to start and has been fine for a while now.
 

·
Registered
2022 SDR Evo
Joined
·
66 Posts
Discussion Starter · #27 ·
Well...the bike took two attempts today. First try it started for a second and stalled. 2nd it fired right up. Now...the outside air temperature was 38 F. The garage temp was 65 F. Not sure if that matters, but it has not done this in a few weeks. Going to keep my phone ready for some video next time.
 

·
Registered
Joined
·
647 Posts
May be try some injector cleaner in a tank of gas, but also check the earth connections on battery cables to the frame etc. Also, was your Tech pac installed before the first 1000km (600mile) service?
 

·
Registered
2022 SDR Evo
Joined
·
66 Posts
Discussion Starter · #30 ·
May be try some injector cleaner in a tank of gas, but also check the earth connections on battery cables to the frame etc. Also, was your Tech pac installed before the first 1000km (600mile) service?
My Tech pac was installed after my 600 mile service. This problem has been going on since new though. I was starting in Sport mode before. Now the bike has never left Performance mode since I got it installed ;)
 

·
Registered
Joined
·
825 Posts
Mode should not have an impact to be honest anyway. The main difference between the modes is the electronic throttle map. They play with the % throttle opening vs % throttle grip position.

Mine is 100% old the time in “performance” mode with ”race” throttle map, and I’ve never had an issue with starting.
 

·
Registered
Joined
·
86 Posts
When I had issues with the suspension electronics early on, the dealer techs capabilities were very limited and everything was handled through remote connect with KTM.

It's my impression dealer service techs handle the basic troubleshooting and physical repairs but a remote tech from KTM would be the one addressing more advanced issues, making software changes, troubleshooting electronics, etc.
Ktm doesnt train or update its mechanics, when i had my pre adjuster Error in my 2022 1290 Evo (
last month), the mechanic was not even sure if the semiautomatic suspension has a separate Ecu or not?? They ask doubts online and do the work
 

·
Registered
Joined
·
86 Posts
My Tech pac was installed after my 600 mile service. This problem has been going on since new though. I was starting in Sport mode before. Now the bike has never left Performance mode since I got it installed ;)
Pls will the dealer install the tech pack after 600 mile service for 2022 1290 sdr Evo?? Pls clarify, i had it presinstalled @ Kilometer zero on my 2018 Ktm 1290 Sdr. The dealer he will do it later ?? I dont believe him anyway. And he doesnt have his diagnostic cable.
 

·
Registered
2022 SDR Evo
Joined
·
66 Posts
Discussion Starter · #38 ·
This one is about 8hrs after the one I posted above. It was when I was leaving work to go home. Seemed to idle higher than normal but it did start first try. Ambient temp was around 58 F.


This one is this morning. Seemed worse than last morning. Ambient temp was like 37F. Bike is kept in a heated garage so it was probably close to 60F in there. I pull it out in the driveway and then start it.

Wonder if bike isn't expecting the colder air after being in the heated garage. I'm just reaching for straws here. No other bike ever cared. Even my SMCR.
 

·
Registered
2022 SuperDuke 1290R Evo
Joined
·
13 Posts
Me and my brother bought 2 new SDR 22 Evo and both bikes had rough cold cranking. It takes 2-3 times for the bike to have a low idle. We have a first maintenance at the dealer next week. We'll see what they will say about it...
 

·
Registered
Joined
·
86 Posts
This one is about 8hrs after the one I posted above. It was when I was leaving work to go home. Seemed to idle higher than normal but it did start first try. Ambient temp was around 58 F.


This one is this morning. Seemed worse than last morning. Ambient temp was like 37F. Bike is kept in a heated garage so it was probably close to 60F in there. I pull it out in the driveway and then start it.

Wonder if bike isn't expecting the colder air after being in the heated garage. I'm just reaching for straws here. No other bike ever cared. Even my SMCR.
See ur video, the bike started after 2 cranks! Mine does the same . Weather is same here throughout the year, Temp here is 90 f
 
21 - 40 of 44 Posts
Top