KTM Forums banner
1 - 8 of 8 Posts

Registered
Joined
3 Posts
Discussion Starter · #1 ·
Hi !
I have a 50 sx 2017 and it have bad idle and when i rev the engine it takes 3 -4 sec to lower the rpm, it overheated lastyear but run pretty good after. Had a leak on the coling system
I tried everything i think 馃槴
It starts easy when cold or hot but only when choke is on !? When its low rpm its like it to little fuel and hard to rev whit full trottle

Engine total rebuild 10 hours ago
New reeds + gasket
New spark
Tried swapping coil and coil
Total cleaning of carburator
New gasoline 2% oil like always

thanks for the help
 

Super Moderator
Joined
2,986 Posts
Hi !
I have a 50 sx 2017 and it have bad idle and when i rev the engine it takes 3 -4 sec to lower the rpm, it overheated lastyear but run pretty good after. Had a leak on the coling system
I tried everything i think 馃槴
It starts easy when cold or hot but only when choke is on !? When its low rpm its like it to little fuel and hard to rev whit full trottle

Engine total rebuild 10 hours ago
New reeds + gasket
New spark
Tried swapping coil and coil
Total cleaning of carburator
New gasoline 2% oil like always

thanks for the help
Vaelkommen till forumet!
(I change to English so all can understand).
  • What jets are you using?
  • What needle is in the carbi?
  • What place is the circlip on the needle?

We had a similar issue on our 50sx (a few years ago now...). The problem was that the float needle had dug a mark in the metal tang on the float and this made the needle be on a small angle and not able to close the fuel flow. New float fixed the issue.

  • Also try to adjust the air screw. Normally 1 1/2 turn open from fully closed.
  • Check the fuel flow from the tank. Let it go in to a container and see if the flow changes.
  • Revs not dropping straight away when throttle is released could indicate an air leak in the inlet manifold to the motor (between carbi and motor. Spray some ether ("Start Ya Bastard") on the manifold when bike idles. If the revs go up you need to find the air leak!

Come back if this did not solve the issue and we dig deeper. (Also let is know if you sorted the problem!
 

Registered
Joined
3 Posts
Discussion Starter · #3 ·
Hi thanks for the help
Mainjet #95
The other is 50 i think
I cant see any marks on the float needle but i will check again.
I think the inlet manifold is bad , its a crack in the rubber on the inside 馃 , the airscrew is not helping and the fuel is good no vacuum in tank, i try to switch manifold 馃憤
 

Super Moderator
Joined
2,986 Posts
Hi thanks for the help
Mainjet #95
The other is 50 i think
I cant see any marks on the float needle but i will check again.
I think the inlet manifold is bad , its a crack in the rubber on the inside 馃 , the airscrew is not helping and the fuel is good no vacuum in tank, i try to switch manifold 馃憤
As mentioned, you can spray Ether on the manifold. If the revs go up you have a crack in the manifold and you need to replace it!
 

Registered
Joined
3 Posts
Discussion Starter · #5 ·
oki now I have changed the manifold, and the bike runs perfectly. Nothing happened when I sprayed around the rubber though.
thanks for the help!
maybe someone is reading this who has the same problem in the future.
馃槑
 

Super Moderator
Joined
2,986 Posts
oki now I have changed the manifold, and the bike runs perfectly. Nothing happened when I sprayed around the rubber though.
thanks for the help!
maybe someone is reading this who has the same problem in the future.
馃槑
Well done!
 

Registered
Joined
6 Posts
ok jumping on this thread hoping for help...to recap the history on our 2-16 ktm sx, the bike had been running just fine in february when we replaced the kickstart mechanism, two weeks later bike would not start at all. Now that we sorted out the clutch oil issue, we have the thinner clutch oil in our 2016 ktm sx, it will start and run if on the throttle...but not idle well (really low) and sometimes not at all. My husband is getting zero change when adjusting the idle screw. Also the drag still seems a bit tight on the back tire but it will rip down our driveway

what we have done so far:
new oil
clutch has less than 1 hr on it
new piston and rings (trying to sort out the idle issue)
new reeds
cleaned and lubricated the chain
new coil and stayter
new kickstart mechanism
carb and jets have been cleaned a few times now. Maybe it needs a rebuild?
I might be forgetting something...but the bike is basically like new now.

please advise-motomomager
 

Super Moderator
Joined
2,986 Posts
ok jumping on this thread hoping for help...to recap the history on our 2-16 ktm sx, the bike had been running just fine in february when we replaced the kickstart mechanism, two weeks later bike would not start at all. Now that we sorted out the clutch oil issue, we have the thinner clutch oil in our 2016 ktm sx, it will start and run if on the throttle...but not idle well (really low) and sometimes not at all. My husband is getting zero change when adjusting the idle screw. Also the drag still seems a bit tight on the back tire but it will rip down our driveway

what we have done so far:
new oil
clutch has less than 1 hr on it
new piston and rings (trying to sort out the idle issue)
new reeds
cleaned and lubricated the chain
new coil and stayter
new kickstart mechanism
carb and jets have been cleaned a few times now. Maybe it needs a rebuild?
I might be forgetting something...but the bike is basically like new now.

please advise-motomomager
  • Check that the fuel flows well from tank. Take hose off carbi, turn on tap and allow fuel to flow in to a bowl for a minute and keep eye on flow.
  • Check that float and float valve works well and allows the fuel to flow in to bowl.
  • Is the 50sx fitted with a power valve?
 
1 - 8 of 8 Posts
Top