KTM Forums banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Bike of the Month Challenge!

1 - 8 of 8 Posts

·
Registered
Joined
·
111 Posts
Discussion Starter · #1 ·
It seems I have a coolant leak on my 2019 SDR.... I can not even see where the leak comes from....

101500
 

·
Registered
Joined
·
343 Posts
I had a leak in exactly the same spot after refreshing mine but reusing the crush washer. Replaced it with a metal washer (and wrapping the thread in teflon) I got from a parts shop for a dime. Never leaked again.

Judging by the spray and distance, yours seems to have found a leak under pressure at the drain plug and looks to be the same problem. Probably looks more dramatic than it is.
 

·
Registered
Joined
·
111 Posts
Discussion Starter · #4 ·
I had a leak in exactly the same spot after refreshing mine but reusing the crush washer. Replaced it with a metal washer (and wrapping the thread in teflon) I got from a parts shop for a dime. Never leaked again.

Judging by the spray and distance, yours seems to have found a leak under pressure at the drain plug and looks to be the same problem. Probably looks more dramatic than it is.
Sure, it happened under pressure during a hot day, riding... "spirited"!! I'll check the washer.

The dealer called and offered me a even swap for a new 2021 Blue/Orange SDR.... and then I woke up finding my coffee cold.... :)
 

·
Registered
Joined
·
705 Posts
Sure, it happened under pressure during a hot day, riding... "spirited"!! I'll check the washer.

The dealer called and offered me a even swap for a new 2021 Blue/Orange SDR.... and then I woke up finding my coffee cold.... :)
Yeah that's either from the drain bolt, coming out the end of the hose from the clamp not being secured proper, or a tiny fissure in the water pump cover. Either are easy to fix
 

·
Registered
Joined
·
111 Posts
Discussion Starter · #6 ·
Yeah that's either from the drain bolt, coming out the end of the hose from the clamp not being secured proper, or a tiny fissure in the water pump cover. Either are easy to fix
First thing I checked was the hose - it was 100%. I guess it may be the washer... hope so. Bike is still under guarantee. Dealer said they will look into it. Nothing a big hammer cant fix! :cool:
 

·
Registered
Joined
·
343 Posts
I'm pretty sure it's the washer, because the drain plug has wear marks on it, indicating it's been loosened at least once. Maybe I'm just seeing things - and that's a reasonable assumption because I'm just a wide-eyed almost-competent home mechanic who on one occasion is able to chop an onion into a hundred pieces one-handed while drinking beer but bangs his shoulder in the doorpost moments later.
 

·
Registered
Joined
·
111 Posts
Discussion Starter · #8 ·
I'm pretty sure it's the washer, because the drain plug has wear marks on it, indicating it's been loosened at least once. Maybe I'm just seeing things - and that's a reasonable assumption because I'm just a wide-eyed almost-competent home mechanic who on one occasion is able to chop an onion into a hundred pieces one-handed while drinking beer but bangs his shoulder in the doorpost moments later.
LOL... same here!!
 
1 - 8 of 8 Posts
Top