KTM Forums banner
1 - 20 of 37 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter · #1 ·
I just bought a 2009 RC8R Acrapovic edition with 3400Km, barely used looks completely new also.
It was from a guy that wanted him for a collectors item, the guy past away not long after. now the RC8R was standing still for years with a friend of his till i bought it.
today i got my tax-plate and wanted to put him to the test, first km i was driving very easy until the engine was fully warmed up; then i was trying to feel the power by accelerating a little more aggressive not full throttle, but every time i did this he was falling dead not going faster for a km/h instead he was going slower until i loosen the throttle and then he was driving again or accelerate very slowly. Can anyone help me with this?

My guess it never had a filter change the gasoline in the tank probably years old, the break fluid looks very dark. some things i need to do for sure? the falling dead was in road mode, when i stopped for a couple of minutes i put the mode in race and drove home i couldn't test it fully but it seems the problem was gone, is there a limit in road mode maybe. Please i would appreciate some help and explanation.
 

·
Registered
Joined
·
59 Posts
I just bought a 2009 RC8R Acrapovic edition with 3400Km, barely used looks completely new also.
It was from a guy that wanted him for a collectors item, the guy past away not long after. now the RC8R was standing still for years with a friend of his till i bought it.
today i got my tax-plate and wanted to put him to the test, first km i was driving very easy until the engine was fully warmed up; then i was trying to feel the power by accelerating a little more aggressive not full throttle, but every time i did this he was falling dead not going faster for a km/h instead he was going slower until i loosen the throttle and then he was driving again or accelerate very slowly. Can anyone help me with this?

My guess it never had a filter change the gasoline in the tank probably years old, the break fluid looks very dark. some things i need to do for sure? the falling dead was in road mode, when i stopped for a couple of minutes i put the mode in race and drove home i couldn't test it fully but it seems the problem was gone, is there a limit in road mode maybe. Please i would appreciate some help and explanation.
You did not mention if you did any mechanical work prior to attempting to use it, in that state there are any number of things that can go bad. Spark plugs, injectors, fuel filter & fuel pump(if it has one) could plug, Oil & filters would definitely need to be changed, the hydraulic fluid most definitely be changed out, check your hydraulic lines for any decay, tires should be checked for any signs of rot.

This would be on par with taking a jet from the boneyard and running it again without a full dissasessembly and checklisting every part. What kind of collector leaves oil and other stuff in their bike while it just sits there.. :nerd:

I doubt it would be the oil but that would be the first thing i'd change, check the fuel system, electrical system and plugs, make sure it's feeding fuel and sparking properly.
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #4 ·
thanks for the reply, i didn't do any mechanical work, i was kinda expecting the seller did a checkup and make it drive ready, the friend of the owner happens to be a guy that sells bikes for a living, first thing tomorrow i'm going to check all the things you mentioned, stupid of me to not do this in the first place. don't know the exact story of the bike just the tail the seller told me, but when its in neutral and i yank the throttle it runs smooth as hell, but in gear and demand some power above 5 a 6000 rpm it holds in and stops accelerating.
 

·
Registered
Joined
·
413 Posts
Change all fluids including gas.
Replace fuel filter.
Replace air filter.
Replace spark plugs.
Check fuel lines and all hoses etc for decay, hardening or cracking. Replace as necessary.
Put injector cleaner into fresh gas.
Unhook the battery for a couple minutes, turn on and let idle for 15 minutes without touching throttle whatsoever. Turn bike off. This will make the ECU do a re-learn of the map, checking the O2 sensors and adjust accordingly.
 

·
Registered
Joined
·
99 Posts
Change all fluids including gas.
Replace fuel filter.
Replace air filter.
Replace spark plugs.
Check fuel lines and all hoses etc for decay, hardening or cracking. Replace as necessary.
Put injector cleaner into fresh gas.
Unhook the battery for a couple minutes, turn on and let idle for 15 minutes without touching throttle whatsoever. Turn bike off. This will make the ECU do a re-learn of the map, checking the O2 sensors and adjust accordingly.
This :yes:

Also try and reset the RPM limit to 10-10.5k, iirc the street setting is at 6k from the factory and seeing as you said the bike has limited use, it's most likely the previous owner ever altered it.
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #7 ·
Thanks a lot for the great help, i changed the gas filter, oil filter, oil and put injector cleaner in the tank and fill the tank up with gas it was already the second tank with fresh gas, also checkt the tubes and there where looking good, i put the rpm limit from the start to 10 - 10.5, just back from a test drive and what the hell it was driving great, did forget to disconnect the battery, was to late with reading your post but it seems it was not necessary, one concern when i'm driving below 70 km/h the temp is rising up till 90-100 degrees is this normal? does not exceed 102 degrees something to worry about? crazy heat is rising up from the motor block pretty hot for the legs, pretty obvious such a bike is not made to drive below 70 but try that to explain to the cops. thanks again for the good pointers, best bike ever. cheers
 

·
Registered
Joined
·
99 Posts
Good to hear. Yes the 8's do run hot at slow speed and particularly in stationary traffic, waiting for traffic lights etc....so normal. I have fitted a secondary radiator fan switch, which gives the option of having the fan run without waiting for the thermostat to engage. Maybe worth a coolant system flush and refill at some point, just to tick a box really.
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #9 ·
thanks, that switch isn't a bad idea, can you explain a bit how you did this, where exactly you connect the cable of the switch? also maybe you know why my akrapovic edition don't have a ... of 100 series plate?
 

·
Registered
Joined
·
99 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter · #11 ·
nice, thanks for this, i read your post on the id plate, you think someone would change a normal rc8r to an akrapovic edition and then after don't ask the money for it, 3400km looks brand new and payed 9000€ for it
 

·
Registered
Joined
·
99 Posts
nice, thanks for this, i read your post on the id plate, you think someone would change a normal rc8r to an akrapovic edition and then after don't ask the money for it, 3400km looks brand new and payed 9000€ for it
You're welcome bud. The Akrapovic LE is one of the most copied models, it's relatively easy to do, as it's basically a 2009/10 R model with different paint and decals. The "real" LE's all came with the ID# attached. Tdel here has a genuine one, so he could give more info I suspect.
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #14 ·
wow you actually drilled a hole in your fender, don't know if i get it over my hart to do that, maybe i find a place that not needs drilling in the fiberglass,
 

·
Registered
Joined
·
99 Posts
I did mate, but mines a track use only. It'd be easy enough to locate the switch on a street bike though without drilling anywhere.
 

·
Registered
Joined
·
99 Posts
Yes, all standard WP front, rear and steer damper. But only the Track model came fitted with the higher spec WP rear shock fitted as standard.
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #18 ·
this doesn't looks good, probable no LE then, but he looks like it and i think for an amateur like me i won't be able to tel the difference if i was riding a real LE or a copy, only 10hp less i think
 
1 - 20 of 37 Posts
Top