KTM Forums banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Bike of the Month Challenge!
1 - 6 of 6 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter · #1 ·
Engine oil is pumping through the 3 stator leads all the way to the connector @ the voltage regulator where it collects and drips down fairing to ground! Any one hear of such a thing? Replaced stock stator with OEM @ 25,000 mi. after it fried. The OEM unit lasted about 5,000 mi. until leak developed. Thinking the leads failed @ the coil, I replaced it with another OEM unit, which started leaking in the same fashion after 300 miles! Any thoughts welcome
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #3 ·
stator leak

No pics available, I should add, the grommet at the crankcase is dry, as is the three stator leads passing through the grommet. I'm certain engine oil is being pushed inside the lead(s) and exiting at the voltage regulator connector!
 

·
Registered
Joined
·
347 Posts
There is supposed to be sealant by those leads. KTM scrimps on sealant and I rebuilt my engine due to lack of sealant.
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #5 ·
"leaking" regulator

Thanks for your input, glad this is not unheard of. Going to pop off that cover and get to gluing.
 

·
Registered
Joined
·
347 Posts
you might need a puller for the ignition cover. Ive the KTM one, but you can do it by pulling from the plug/cap area I bet. Reseal the entire cover area and plug gap area with Yamabond or PermTEX (i used grey. black or blue likely works too).

Youll need a 14mm hex/allen to remove the ignition cap as well.
 
1 - 6 of 6 Posts
Top