KTM Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi All!

I own a 2013 KTM EXC-f 350. Due to work requirements and procrastination, I did not take the correct steps to get my bike ready for winter storage. Now, I am paying the price. I did not remove any fuel and pretty much just let the bike sit in the garage from November - May.

Last week, I began working on the bike and replaced a couple plastics, did an oil change, and cleaned the air filter. I had to use the bike for a 20 minute ride to get to my parents house ,where I watched my dog for the night. The following day, I went to ride it back home and it would crank but not start. After a couple attempts the FI light came on and the cranking dwindled down. Eventually I ended up push-starting it just to get me home. I figured it was an old battery, so I replaced that but now the bike makes no sound when turning the key and disabling the kill switch. The battery is new and set up correctly so I am not sure what this issue can be.

I have a few things in mind but wanted to reach out first to see if anyone has experienced this problem and if they would be so kind as to point me in the right direction. Any help would be appreciated, thank you!!
 

·
Registered
2012 KTM 350 EXC-F
Joined
·
3 Posts
Did an oil change recently on my exc 350 and wouldn’t start no matter what I did. Ended up being a combo of bad fuel and spark plug. Had to boost the bike from the truck because the battery would die super fast after cranking it so long. Yours on the other hand sounds like a bad battery or bad electrical connection. I would definitely replace the old fuel, change plug and test battery and check that all connections are tight and clean.

Let me know how it goes.
 
1 - 2 of 2 Posts
Top