KTM Forums banner
21 - 27 of 27 Posts

·
Registered
Joined
·
3 Posts
I'm losing half the volume in my reserve bottle after parking. There seems to be no loss of coolant during operation. No visible external leaks, no steam in exhaust, no coolant in crankcase. Could this missing fluid be just "boiling off", I'm at a complete loss. Also, does anyone know if the 2012 1190 waterpump has a weep hole, can't seem to locate it.
 

·
Registered
Joined
·
49 Posts
I solved my problem, I ordered the water pump seal kit, I changed the seals and the bushing, the bushing had signs of wear and it had a small groove in it, I assume that's where the coolant was going through in to the engine/oil. Easy fix, hope this comes in handy.
 

·
Registered
Joined
·
347 Posts
I also thought I was loosing coolant somewhere upon my rebuild. But I filled it to full after it went down. ...it then proceeded to pour out the overflow at a bike meet lol.

I attributed it to air in the system as the temps would rise and fall fairly drastically at first, and that I never did the bleed from the heads.

6000kms later and it's a lot more solid after venting some air. Though. ..still leaking a little too add it appears lower.

Oil seems fine, no remnants of coolant (I used water wetter though) and If I fill it, it overflows again lol. It never drops past min.

Maybe I'll bleed the system after all.
 

·
Registered
Joined
·
1 Posts
Hi Folks,

Adding to this old thread in case it might help other. I have purchased in 2021 a 2015 RC8R with 4500 miles. Bike was in perfect condition, OEM tires, no sign of abuse whatsoever.
A few hundred miles in, I noticed coolant smell but was unable to find a leak and the water level in the reservoir seemed stable. Fast forward to a track day a month later, the leak was large enough to create a small pool of water under the bike. Mind you, it was in spring, the bike never went past 90'C.
It took a closer inspection to finally locate a tiny squirt coming from the upper left corner of the radiator. See video (RC8R Coolant Leak). I was unable to find a crack after removing the radiator as it seems the leak comes from between the fins.
Long story short, I ended looking for a new radiator and noticed that KTM has superseded the old Ref. 69035010100 with a new one: 69035010200. the new radiator is painted black and does not show the WP markings from the previous model. I guess KTM changed manufacturer.
When reinstalling the radiator, I was unable to get the upper left mount aligned with the bolt. The rubber grommet used for vibration dampening looked stretched. Digging into the matter further, I saw that a small plastic fender located immediately above the radiator, was pushing down on it. I trimmed the mounting tabs of said fender to give more clearance to the radiator and relieve the stress I saw on the grommet. I'll let you know how the fix and the new radiator work out.

Hope it helps somebody else.

103543

103544

103545
 
21 - 27 of 27 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top